TLS Negotiation failed, the certificate doesn’t match the host.

Da habe ich ein wenig doof geguckt, als mir Google-Mail beim Versenden einer Nachricht diese Meldung präsentierte. Abhilfe ist aber augenscheinlich recht einfach.

Ich sende über Gmail Mails mit meiner eigenen Domain. Dazu habe ich meinen SMTP-Server dort eingetragen. Da die Domain natürlich auf einem etwas größeren Server liegt, bedient dieser alle möglichen Domains. Ich habe nun immer smtp.meine-domain.de genutzt – und genau das scheint nicht mehr zu funktionieren. Flugs auf den Namen des eigentlichen Servers geändert und schon gehen die Mails wieder raus.

Verwendete Schlagwörter: , , , ,

5 Comments on “TLS Negotiation failed, the certificate doesn’t match the host.

  1. Hallo, ich habe eben genau dieses Problem in meinem Shop von WordPress bzw. Woocommerce. Es kommen immer die Mails von Outlook Kunden nicht an mit dieser Fehlermeldung. Habe schon sämtliche Einstellungen gemacht und scheinen auch richtig zu sein. Was muss ich wo noch einstellen damit das mit den Mails auch bei Outlook geht? Muss ich da noch im Server/Host was einstellen??

    • Ausgehende Mails kommen nicht an? Dann habe ich die Lösung im Beitrag doch beschrieben. Möglicherweise nutzt Du in der Konfiguration des Shops einen SMTP-Namen wie z.B. smtp.meine-domain.de … der Server auf dem der Shop läuft, heisst aber server-des-providers.com und auf den ist im Zweifel dann das Zertifikat ausgestellt. Du müsstest dann in den Shop-Einstellungen den SMTP-Server auf server-des-providers.com ändern (sofern das dann immer noch funktioniert) oder den Provider bitten, ein Zertifikat zu installieren, welches auch für smtp.meine-domain.de gilt.

  2. Hallo, ich hab auch das Problem. Meine Adresse ist eine web.de Adresse. Wie kann ich das da neu einstellen?
    Es kommt immer folgende Meldung:
    “Die Nachricht wurde nicht zugestellt
    Sie senden diese Nachricht von einer anderen E-Mail- oder Alias-Adresse mithilfe der Funktion “Senden als”. Die Einstellungen für das unter “Senden als” angegebene Konto sind falsch konfiguriert oder nicht mehr aktuell. Überprüfen Sie diese Einstellungen und versuchen Sie, die Nachricht noch einmal zu senden.”

    Googles Hilfe hilft leider nicht ;-)
    Danke vorab!

    • Hi, seit ein paar Tagen hatte auch ich das Problem mit einer web.de-Adresse. Ich habe die Verknüpfung nun einmal aufgehoben und wieder erneut eingerichtet und nun funktioniert es wieder.

Schreibe einen Kommentar zu Special K Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*