Das Aldi-Medion NAS setzt beim Kopieren ein neues Dateidatum

Und was sich in der Überschrift so unspektakulär anhört, macht es in der Praxis so gut wie unbrauchbar! Ich benutze bereits ein NAS von Western-Digital und kopiere dort mit einer Robocopy-Batch-Datei die zu sichernden Daten drauf. Das klappt seit Jahren – zunächst auf einen extra Server und nun auf das NAS – problemlos.

Mit der Zeile
robocopy “d:\film” “\\NAS2TB\Public\Shared Videos” /MIR /FFT /XF *.log /copy:dt
werden z.B. alle auf der Platte befindlichen Filme gesichert. Beim nächsten Backupvorgang erkennt Robocopy anhand des Dateidatums, ob er eine Datei erneut rüber schieben soll, oder ob die Datei schon vorhanden ist. Wie soll es auch sonst erkannt werden?

Das doofe NAS von Aldi setzt nun bei jedem Kopiervorgang das Erstellungs-, das Änderungsdatum und das Datum des letzten Zugriffs auf die jeweils aktuelle Systemzeit – und macht damit die Datei für eine Sicherung unbrauchbar. Auch als Datenspeicher bringt das dann nichts. Wie will man seine Bilder z.B. nach Datum sortieren lassen, um nur mal ein einfaches Beispiel zu nennen. Was mich dabei wundert ist, dass die Erstellungs- bzw. Änderungsdaten der Ordner augenscheinlich korrekt gesetzt werden. Nur die Datei bekommen einen falschen Zeitstempel. Und auch das erst nach ca. 10 Sekunden! Erst wird die Datei mit korrektem Datum angezeigt und nach einer kurzen Zeit, ändert sich dieses plötzlich.

Die anderen Funktionen des Medion-NAS sind super, aber damit kann man leider nicht arbeiten. Und es liegt nicht ein mir. Ein noch erfahrener Oeynhausener Blogger hat das gleiche Problem.

Nachtrag 1: Um es noch verrückter zu machen … das passiert bei *fast* allen Dateien. Aber ohne nachvollziehbaren Grund, wird bei einem Bruchteil der Daten der Zeitstempel korrekt gesetzt. Manchmal auch einfach nachdem der gleiche Robocopy-Befehl mehrfach ausgeführt wurde. Das ist doch Scheiße!

Nachtrag 2: Wie immer ist es so, dass aufschreiben und aufregen hilft. Ich habe natürllich neben dem Schreiben des Artikels und gestern abend schon in einer Tour probiert. Es scheint, dass der Parameter /Z die Lösung ist. Damit kopiert Robocopy im “Restart Modus”. Warum das dazu führt, dass das NAS das Dateidatum nicht ändert, wird ein Geheimnis bleiben. Mit der Zeile
robocopy “d:\film” “\\NAS2TB\Public\Shared Videos” /MIR /FFT /DCOPY:T /copy:dt /zb /r:1 /w:10
funktioniert das Backup auf das Medion-NAS jetzt jedenfalls wie gewünscht!

Getagged mit: , ,
2 Kommentare zu “Das Aldi-Medion NAS setzt beim Kopieren ein neues Dateidatum
  1. Werner sagt:

    Hallo Andreas!
    Dein Tip mit “/zb” hat schon mal viel geholfen. (Ich habe ein Medion P89631 mit 3 TB.) Leider ist das Datum-Problem nur zu ca. 90 % gelöst. Als mißtrauischer Mensch habe ich natürlich mit dem Total Commander die Dateien verglichen und, grand malheur de kack, bei einer erheblichen Anzahl von Dateien stimmen die Zeiten nicht überein. Auch ein zweiter Kopierlauf brachte keine Änderung. Eigentlich funktioniert robocopy ja so, daß Dateien mit einem anderen Datum auch bei gleicher Größe gnadenlos überschrieben werden. Bei diesem Gerät ist das aber wohl nicht der Fall. Sehr bizarr.

    Noch etwas ist mir aufgefallen. Das Gerät soll sich ja seine interne Zeit vom Internet holen, bei mir von de.pool.ntp.org. Das tut es aber nicht von selbst, ich muß die Zeitsynchronisierung immer manuell anstoßen.

    mfg
    Werner

  2. Gregor sagt:

    Hallo,

    ich habe das gleiche Problem mit meinem Medion NAS und schicke inzwischen einen zweiten robocopy befehl hinterher, der nur den Zeitstempel korrigiert.

    ROBOCOPY “%quelle%” “%ziel%” /MIR /FFT /DST /ZB /DCOPY:T /R:0 /W:1 /NP /TIMFIX /LOG:”%Logfile%” /XD “%aus%”
    ROBOCOPY “%quelle%” “%ziel%” /E /FFT /DST /ZB /COPY:T /R:0 /W:1 /NP /LOG+:”%Logfile%” /XD “%aus%”

    Das scheint zu funktionieren

    Mfg Gregor

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Ich akzeptiere

*